Library Express

Library management software

• Requires Windows 7, Windows Vista, Windows XP Service Pack 2 or Windows 2000 SP 4.

• During the installation, click the Help button on the installer screen for additional assistance.

For Support

For queries about your license:

Community forum:

Other technical queries:

Get the Extras

Latest Update(v1.0.31)

Collection Browser